IDN Networking Competition 2017: Mikrotik Bridging Challenge Solution

Sebelum kamu melakukan copy paste konfigurasi yang akan saya paparkan dalam postingan ini, pastikan penamaan interface pada virtualisai router yang kamu gunakan sudah benar. Kamu bisa ikuti tutorial Mengurutkan Interface pada Virtualisasi Router Mikrotik di Qemu untuk memastikannya

Pada post kali ini saya berusaha memaparkan pendekatan yang saya gunakan untuk menyelesaikan soal bridging pada kompetisi IDN networking 2017 untuk materi superlab Mikrotik, dimana soal dapat dapat di unduh pada link berikut. Untuk soal bridging (no 2 s/d 6), kita akan fokus pada topologi jaringan di kantor pusat Jakarta. Adapun topologinya adalah sebagai berikut.

Kantor pusat Jakarta juga memiliki informasi VLAN sebagai berikut:

VLAN IDNetworkDescription
10192.168.10.0/24Guest
20192.168.20.0/24Karyawan
30192.168.30.0/24Admin
40192.168.40.0/24Network Admin
99192.168.99.0/24Management

Pendekatan yang saya paparkan dalam panduan ini belum tentu solusi yang paling baik namun saya berusaha mengikuti standar penamaan yang di jelaskan di manual yang berada di website mikrotik. Maka dari itu logical topology yang saya propose adalah sebagai berikut:

Dari topologi diatas dapat kita lihat bahwa semua VLAN bermuara ke router Core-JKT melalui path yang jelas dari ujung ke ujung. Sebagai contoh untuk VLAN 99 dari R-L2-2 dapat menuju ke Core-JKT dikarenakan ada path yang berkelanjutan dari R-L2-2 ke Core-JKT melaui R-L2-1 (dapat dilihat dari path warna hitam). Selanjutnya mari kita masuk ke tiap-tiap router untuk membedah konfigurasi yang perlu kita set di tiap router.

Core-JKT

Core-JKT sebagai pusat dari semua router yang ada di kantor Jakarta harus memiliki semua konfigurasi VLAN yang ada di kantor Jakarta, dari gambar di atas, dapat kita simpulkan bahwa untuk Core-JKT kita perlu mengkonfigurasi router dengan membuat bridge and VLAN sebagai berikut:

Bridge

  • bridge-vlan10
  • bridge-vlan20
  • bridge-vlan30
  • bridge-vlan40
  • bridge-vlan99
ether3

  • ether3-vlan10
  • ether3-vlan20
  • ether3-vlan30
  • ether3-vlan99
ether4

  • ether4-vlan10
  • ether4-vlan20
  • ether4-vlan30
  • ether4-vlan40
  • ether4-vlan99
ether5

  • ether5-vlan30
  • ether5-vlan40
  • ether5-vlan99

Dengan perencanaan diatas, berikut konfigurasi yang dapat kita gunakan.

/interface bridge
add name bridge-vlan10
add name bridge-vlan20
add name bridge-vlan30
add name bridge-vlan40
add name bridge-vlan99
/interface vlan
add interface=ether3 name=ether3-vlan10 vlan-id=10
add interface=ether3 name=ether3-vlan20 vlan-id=20
add interface=ether3 name=ether3-vlan30 vlan-id=30
add interface=ether3 name=ether3-vlan99 vlan-id=99
add interface=ether4 name=ether4-vlan10 vlan-id=10
add interface=ether4 name=ether4-vlan20 vlan-id=20
add interface=ether4 name=ether4-vlan30 vlan-id=30
add interface=ether4 name=ether4-vlan40 vlan-id=40
add interface=ether4 name=ether4-vlan99 vlan-id=99
add interface=ether5 name=ether5-vlan30 vlan-id=30
add interface=ether5 name=ether5-vlan40 vlan-id=40
add interface=ether5 name=ether5-vlan99 vlan-id=99
/interface bridge port
add bridge=bridge-vlan10 interface=ether3-vlan10
add bridge=bridge-vlan10 interface=ether4-vlan10
add bridge=bridge-vlan20 interface=ether3-vlan20
add bridge=bridge-vlan20 interface=ether4-vlan20
add bridge=bridge-vlan30 interface=ether3-vlan30
add bridge=bridge-vlan30 interface=ether4-vlan30
add bridge=bridge-vlan30 interface=ether5-vlan30
add bridge=bridge-vlan40 interface=ether4-vlan40
add bridge=bridge-vlan40 interface=ether5-vlan40
add bridge=bridge-vlan99 interface=ether3-vlan99
add bridge=bridge-vlan99 interface=ether4-vlan99
add bridge=bridge-vlan99 interface=ether5-vlan99

Jangan lupa untuk konfigurasi IP address serta DHCP server di Core-JKT adalah sebagai berikut

/ip address
add address=192.168.10.1/24 interface=bridge-vlan10 network=192.168.10.0
add address=192.168.20.1/24 interface=bridge-vlan20 network=192.168.20.0
add address=192.168.30.1/24 interface=bridge-vlan30 network=192.168.30.0
add address=192.168.40.1/24 interface=bridge-vlan40 network=192.168.40.0
add address=192.168.99.1/24 interface=bridge-vlan99 network=192.168.99.0
/ip pool
add name=dhcp_pool_vlan_10 ranges=192.168.10.10-192.168.10.254
add name=dhcp_pool_vlan_20 ranges=192.168.20.10-192.168.20.254
add name=dhcp_pool_vlan_30 ranges=192.168.30.10-192.168.30.254
add name=dhcp_pool_vlan_40 ranges=192.168.40.10-192.168.40.254
/ip dhcp-server
add address-pool=dhcp_pool_vlan_10 disabled=no interface=bridge-vlan10 name=dhcp_vlan_10
add address-pool=dhcp_pool_vlan_20 disabled=no interface=bridge-vlan20 name=dhcp_vlan_20
add address-pool=dhcp_pool_vlan_30 disabled=no interface=bridge-vlan30 name=dhcp_vlan_30
add address-pool=dhcp_pool_vlan_40 disabled=no interface=bridge-vlan40 name=dhcp_vlan_40
/ip dhcp-server network
add address=192.168.10.0/24 gateway=192.168.10.1 dns-server=8.8.8.8
add address=192.168.20.0/24 gateway=192.168.20.1 dns-server=8.8.8.8
add address=192.168.30.0/24 gateway=192.168.30.1 dns-server=8.8.8.8
add address=192.168.40.0/24 gateway=192.168.40.1 dns-server=8.8.8.8

R-L1

Untuk R-L1 dapat kita lihat dari diagram diatas, bahwa untuk R-L1 perlu memiliki konfigurasi untuk 4 VLAN yakni VLAN 10, 20, 30 dan 99 dan untuk dapat berkomunikasi dengan pusat Core-JKT, jalan satu satunya adalah melalui interface ether1 sehingga kita perlu membuat semua konfigurasi vlan di ether1 yang nantinya perlu dihubungkan ke bridgenya masing-masing sebagai berikut:

Bridge

  • bridge-vlan10
  • bridge-vlan20
  • bridge-vlan30
  • bridge-vlan40
  • bridge-vlan99
ether1

  • ether1-vlan10
  • ether1-vlan20
  • ether1-vlan30
  • ether1-vlan40
  • bridge-vlan99

Dengan perencanaan diatas, berikut konfigurasi yang dapat kita gunakan.

/interface bridge
add name bridge-vlan10
add name bridge-vlan20
add name bridge-vlan30
add name bridge-vlan40
add name bridge-vlan99
/interface vlan
add interface=ether1 name=ether1-vlan10 vlan-id=10
add interface=ether1 name=ether1-vlan20 vlan-id=20
add interface=ether1 name=ether1-vlan30 vlan-id=30
add interface=ether1 name=ether1-vlan40 vlan-id=40
add interface=ether1 name=ether1-vlan99 vlan-id=99
/interface bridge port
add bridge=bridge-vlan10 interface=ether1-vlan10
add bridge=bridge-vlan20 interface=ether1-vlan20
add bridge=bridge-vlan30 interface=ether1-vlan30
add bridge=bridge-vlan40 interface=ether1-vlan40
add bridge=bridge-vlan99 interface=ether1-vlan99

Selanjutnya adalah konfigurasi ether2, ether3 dan ether4 dimana sesuai dengan topologi dari soal:

  • ether2 adalah bagian dari VLAN 10
  • ether3 adalah bagian dari VLAN 20
  • ether4 adalah bagian dari VLAN 30

Hal ini dapat dengan mudah dilakukan dengan memasukkan tiap interface kedalam keanggotaan port dari bridge sesuai dengan VLAN yang seharusnya berjalan di port tersebut, hal ini sama analoginya dengan konfigurasi access port (port dengan untagged vlan tertentu).

/interface bridge port
add bridge=bridge-vlan10 interface=ether2
add bridge=bridge-vlan20 interface=ether3
add bridge=bridge-vlan30 interface=ether4

Jangan lupa juga untuk konfigurasi R-L1 management IP addresss serta default route supaya dapat terhubung ke internet

/ip address
add address=192.168.99.2/24 interface=bridge-vlan99 network=192.168.99.0
/ip route
add distance=1 gateway=192.168.99.1

R-L2-1

Untuk R-L2-1 dapat kita lihat dari diagram diatas, bahwa untuk R-L2-1 perlu memiliki konfigurasi untuk ke 5 VLAN meskipun host yang terhubung secara langsung ke R-L2-1 hanya masuk kedalam VLAN 10 dan 20. Namun, R-L2-1 menjadi transit dari VLAN yang berada di R-L2-2 untuk dapat berkomunikasi dengan pusat di Core-JKT, Maka dari itu ether3 sebagai penghubung dari R-L2-2 ke R-L2-1, harus memiliki konfigurasi VLAN yang berada di R-L2-2. Sedangkan supaya R-L2-1 dapat berkomunikasi dengan pusat Core-JKT, semua VLAN akan melalui ether1, sehingga kita perlu membuat semua konfigurasi VLAN di ether1 yang nantinya perlu dihubungkan ke bridgenya masing-masing. Perencanaanya adalah sebagai berikut:

Bridge

  • bridge-vlan10
  • bridge-vlan20
  • bridge-vlan30
  • bridge-vlan40
  • bridge-vlan99
ether1

  • ether1-vlan10
  • ether1-vlan20
  • ether1-vlan30
  • ether1-vlan40
  • ether1-vlan99
ether3

  • ether3-vlan30
  • ether3-vlan40
  • ether3-vlan99

Dengan perencanaan diatas, berikut konfigurasi yang dapat kita gunakan.

/interface bridge
add name bridge-vlan10
add name bridge-vlan20
add name bridge-vlan30
add name bridge-vlan40
add name bridge-vlan99
/interface vlan
add interface=ether1 name=ether1-vlan10 vlan-id=10
add interface=ether1 name=ether1-vlan20 vlan-id=20
add interface=ether1 name=ether1-vlan30 vlan-id=30
add interface=ether1 name=ether1-vlan40 vlan-id=40
add interface=ether1 name=ether1-vlan99 vlan-id=99
add interface=ether3 name=ether3-vlan30 vlan-id=30 
add interface=ether3 name=ether3-vlan40 vlan-id=40 
add interface=ether3 name=ether3-vlan99 vlan-id=99
/interface bridge port
add bridge=bridge-vlan10 interface=ether1-vlan10
add bridge=bridge-vlan20 interface=ether1-vlan20
add bridge=bridge-vlan30 interface=ether1-vlan30
add bridge=bridge-vlan40 interface=ether1-vlan40
add bridge=bridge-vlan99 interface=ether1-vlan99
add bridge=bridge-vlan30 interface=ether3-vlan30 
add bridge=bridge-vlan40 interface=ether3-vlan40 
add bridge=bridge-vlan99 interface=ether3-vlan99

Selanjutnya adalah konfigurasi ether2 dan ether3 dimana sesuai dengan topologi dari soal:

  • ether2 adalah bagian dari VLAN 10
  • ether3 adalah bagian dari VLAN 20

Hal ini dapat dengan mudah dilakukan dengan memasukkan tiap interface kedalam keanggotaan port dari bridge sesuai dengan VLAN yang seharusnya berjalan di port tersebut, hal ini sama analoginya dengan konfigurasi access port (port dengan untagged vlan tertentu).

/interface bridge port
add bridge=bridge-vlan10 interface=ether2
add bridge=bridge-vlan20 interface=ether3

Jangan lupa juga untuk konfigurasi R-L2-1 management IP addresss serta default route supaya dapat terhubung ke internet

/ip address
add address=192.168.99.3/24 interface=bridge-vlan99 network=192.168.99.0
/ip route
add distance=1 gateway=192.168.99.1

R-L2-2

Seperti yang kita lihat dari diagram diatas, bahwa untuk R-L2-2 perlu memiliki konfigurasi untuk 3 VLAN yakni VLAN 30, 40 dan 99 dan untuk dapat berkomunikasi dengan Core-JKT melalui R-L2-1, jalan yang ditempuh adalah melalui interface ether1 sehingga kita perlu membuat semua konfigurasi vlan di ether1 yang nantinya perlu dihubungkan ke bridgenya masing-masing sebagai berikut:

Bridge

  • bridge-vlan30
  • bridge-vlan40
  • bridge-vlan99
ether1

  • ether1-vlan30
  • ether1-vlan40
  • bridge-vlan99

Dengan perencanaan diatas, berikut konfigurasi yang dapat kita gunakan.

/interface bridge
add name bridge-vlan30
add name bridge-vlan40
add name bridge-vlan99
/interface vlan
add interface=ether1 name=ether1-vlan30 vlan-id=30
add interface=ether1 name=ether1-vlan40 vlan-id=40
add interface=ether1 name=ether1-vlan99 vlan-id=99
/interface bridge port
add bridge=bridge-vlan30 interface=ether1-vlan30
add bridge=bridge-vlan40 interface=ether1-vlan40
add bridge=bridge-vlan99 interface=ether1-vlan99

Selanjutnya adalah konfigurasi ether2 dan ether3 dimana sesuai dengan topologi dari soal:

  • ether2 adalah bagian dari VLAN 30
  • ether3 adalah bagian dari VLAN 40

Hal ini dapat dengan mudah dilakukan dengan memasukkan tiap interface kedalam keanggotaan port dari bridge sesuai dengan VLAN yang seharusnya berjalan di port tersebut, hal ini sama analoginya dengan konfigurasi access port (port dengan untagged vlan tertentu).

/interface bridge port
add bridge=bridge-vlan30 interface=ether2
add bridge=bridge-vlan40 interface=ether3

Jangan lupa juga untuk konfigurasi R-L2-2 management IP addresss serta default route supaya dapat terhubung ke internet

/ip address
add address=192.168.99.4/24 interface=bridge-vlan99 network=192.168.99.0
/ip route
add distance=1 gateway=192.168.99.1

R-L3

Untuk R-L3 memiliki konfigurasi yang sama dengan R-L2-2, sehingga konfigurasi R-L2-2 untuk bridging dan VLAN dapat diaplikasikan ke R-L3. Namun, untuk konfigurasi IP management harus kita sesuaikan, yakni:

/ip address 
add address=192.168.99.5/24 interface=bridge-vlan99 network=192.168.99.0 
/ip route 
add distance=1 gateway=192.168.99.1

Selanjutnya untuk tahap verifikasi konfigurasi di atas kamu bisa baca di postingan selanjutnya IDN Networking Competition 2017: Mikrotik Bridging Challenge Solution Verification. Kalau ada pertanyaan atau kurang jelas, tolong jangan sungkan untuk meninggalkan pertanyaan melalui komentar. Terima kasih.

Creative Commons License
IDN Networking Competition 2017: Mikrotik Bridging Challenge Solution by Rio Indra Maulana is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
Posted in Computer Network, Configuration, Mikrotik Tagged with: , , , , ,
4 comments on “IDN Networking Competition 2017: Mikrotik Bridging Challenge Solution
  1. pembahasan yang bagusss Mas Rio… 👍👍 lanjutkan writeupnya 😁😁

  2. Detail banget, tuntas..
    Ditunggu write up selanjutnya mas :))

    Oh iya drawing ilustrasi seperti itu dengan bantuan software apa ya?

Leave a Reply

Your email address will not be published. Required fields are marked *

*